From Our Mailbag: Repairing a Roland Cube 80XL

| December 21, 2011 | 1 Comment

repairing a roland cube 80xl“Hi GKB, I know you are featuring work on the micro cube but wonder if you would have a thought regarding a problem I’m having with the COSM switch on my Roland Cube 80XL. The switch doubles as a tuner which works just fine, but after a bumpy ride to a gig, the amp model stays on the same amp in all positions (seems to be stuck on black panel). No outer evidence of any damage and I have only had the amp for a few months. Any suggestions would be helpful as I am not able to get the amp in for service with Roland.
Thanks,
Doc

Doc, we’re happy to try to help diagnose the problem but we need some clarification. How do you know you’re having a problem with the COSM switch? In the owner’s manual there is a Tuner switch, a “Select” switch, and the rotary knob for the different COSM sounds. The select switch changes between the clean lead channel and the COSM effects I believe. You’re saying that the tuner switch is working. What happens with the select switch – does it change between the clean lead and the COSM effects (which you say is stuck on Black Panel)? With the tuner on, try the manual tuning mode – does the rotary knob work in terms of changing the string being tuned?

Couple of other things – make sure there is no footswitch plugged in, since this interacts with the rotary knob setting. Also, do a factory reset to make sure that the solo feature is not getting in the way. To do the factory reset, Hold down the [TAP/STOP] switch and the SOLO [ON/OFF] switch at the same time and switch on the power. The SOLO indicator blinks and the settings saved with the SOLO function are returned to their factory defaults.

Let us know what you find.

* * * UPDATE * * *

Doc writes back:

“Thanks for your help. I reset to factory settings and things seem to be in order – when all else fails, read the manual !
Thanks again, Doc”

Category: The Repair Bench

Comments (1)

Trackback URL

  1. avatar Lucas says:

    Hi GKB I’m having a problem with the COSM switch also!!!
    When the switch is in metal or R-FIER it plays well but on every other mode I try makes a noise.
    Can you help me?

Leave a Reply


nine − 6 =